Help > Hardware

The keyboard layout for Russian-speaking users


I want to see an annoying bug when installing the distro NuTyX Russian-speaking user.
When the installer is run, the user selects the country "Russia".
The installer then asks to add a user:

The user performs the request and enters a name and password are ALWAYS in LATIN characters.
The user then sets the GUI NuTyX commands:

get xorg
get mate mate-extra
get lxdm

And lxdm does not let the user in DE MATE.
The password was specified in Latin characters, and the default keyboard included in the input mode of the Cyrillic alphabet and the way to switch the layout there.
Blame the file /etc/X11/xorg.xonf.d/20-keyboard.conf

--- Code: ---Section "InputClass"
       Identifier "Generic Keyboard"
       MatchIsKeyboard     "yes"
       Option "XkbLayout"  "ru"
--- End code ---
It creates the script setup-nutyx, as it turned out. Here's a line:

--- Code: ---1211 ru*) echo '  Option "XkbLayout" "ru"' >> ${XORGKB};;
--- End code ---

To prevent such a situation did not arise, I suggest a little change the line:

--- Code: ---ru*) echo '  Option "XkbLayout" "us,ru"' >> ${XORGKB};;
--- End code ---

Turn on the Latin keyboard layout and the user can enter the correct password.
File 20-keyboard.conf it will be possible to configure as desired.

That's a realy detail and complete bug report. I will commit your request ASAP


[0] Message Index

Go to full version