Help > Installation

multiple problems with installing

(1/2) > >>

passenger 19:
When I learned of your distro I was quite happy, however during the last three hours I've run into a few complications.

On my machine your large ISO cycles through several "screens" then says it's too quick and will be locked up for twenty minutes.

No problem, I'll use your small, fixed, ISO. 10.5 ....... both md5sum's were correct.

Unfortunately the small ISO won't install Nutyx.

No problem, I'll go the advanced method.

Alas that way rejects partitioning the disc, because there is not GPT table.

Nor will it format anything for exactly the same reason.

Then the install jumps over boot, and everything after set the clock. Yet it quickly drops to a terminal/console.

From which the "finish up your installation" proceeds smoothly.

Well almost.

Upon reboot the machine complains that the file system is unrecognised and proceeds to grub rescue. :'(

I have no idea what the problem is.

Should I...... Format the partition sda1, using another distro, before trying an install?...... I have no idea, as I write, about a GPT table.

I'm not asked to set a root password. Is that standard? And I have no idea what the su password is.

For your reference I'm using a MSI motherboard, (bought in 2018) 4G ram, sba1 is 47G of 1T (where I want/ed to put Nutyx). sdb2 is the swap of 8G of 2T with a i3 (bought in 2018).

Sorry for the length.

I'm afraid, I have a lack of experience in Hardware. A lot of things can be wrong. Possibly something wrong in your partition table configuration. Some combinations are not working on linux. You should clean up your partitions table before you want to try again.
Beside this problem, I 'm like you, I have no idea what can be wrong. I believe installing NuTyX is a bit of chance with your hardware. Not all are compatible, specially the newer ones.

passenger 19:
Not being one to give up easily, I tried again this morning.

Once I worked out how to create a GPT table, the install went smoothly.


As suggested I created a small (100M) EFI partition, and two other partitions, (one for the OS ...100G and one for data...... 800+G)

Alas upon rebooting after the install sda1 was empty.

So the machine dropped to terminal with wee o> before the prompt.

Will moving the 15 EFI files from sda2 to sda1 fix convince the machine to boot into Nutyx?

I can't answer your actual question regarding moving the files. I do know that by design, NuTyX goes on only one partition. Did you happen to find this UEFI installation guide?

passenger 19:

--- Quote from: oyim on Tue Jan 08 23:59:57 2019 ---Did you happen to find this UEFI installation guide?

--- End quote ---

I thought I'd read it properly. What I missed was the size of the partition.

Somehow I read 500M as 50M. .... So though I doubled the first partition size it is only 20% of the minium size required.

I'll try again tomorrow.


[0] Message Index

[#] Next page

Go to full version