Author Topic: qbittorrent: binaries packages not generated  (Read 2232 times)

dufresnep

  • Newbie
  • *
  • Posts: 43
  • Karma: +0/-0
qbittorrent: binaries packages not generated
« on: Mon Oct 21 02:20:04 2019 »
Well, I am trying to generate an iso with gui-extra.
But gui-extra have blocks on qbittorrent.
The binaries have not been produced.
I means, the qbittorrent directory have only the .Pkg file... unlike others packages.

The problem seems to be that configure blocks.

At first I thought it was qmake that was an older version... but looking at the configure.ac, only file existence is
checked not version. Maybe that the following line about svg version that is wrong... clearly I don't know exactly
what is the problem.

Thierry

  • Administrator
  • Hero Member
  • *****
  • Posts: 595
  • Karma: +10/-0
  • Gender: Male
    • NuTyX distribution
Re: qbittorrent: binaries packages not generated
« Reply #1 on: Mon Oct 21 08:17:45 2019 »
Soorry about that . Another lazy mistake from my side.

qbittorrent demand an out of date version of  libtorrent-rasterbar, I didn't find a patch yet for it.
Means for the moment qbittorrent is not available

The depot  gui-extra is fixed with this issue.

Sorry for this inconvegniency.

Thierry

dufresnep

  • Newbie
  • *
  • Posts: 43
  • Karma: +0/-0
Re: qbittorrent: binaries packages not generated
« Reply #2 on: Mon Oct 21 15:39:07 2019 »
>The depot gui-extra is fixed with this issue
It seems not.

I means at first it was blocking at the same place.
Then I did #cards sync
Then it continue, but finally blocked on the same place:
...
/var/lib/pkg/depot/gui/sonnet/.PKGREPO
/var/lib/pkg/depot/gui/sonnet/sonnet1571486826x86_64.cards.tar.xz
    204.60 KB  (238.46 KB/s) 100 % - 0 s   
/var/lib/pkg/depot/gui/kfilemetadata/.PKGREPO
/var/lib/pkg/depot/gui/kfilemetadata/kfilemetadata1571489084x86_64.cards.tar.xz
    124.47 KB  (186.89 KB/s) 100 % - 0 s   
/var/lib/pkg/depot/gui/knotifyconfig/.PKGREPO
/var/lib/pkg/depot/gui/knotifyconfig/knotifyconfig1571502145x86_64.cards.tar.xz
    33.28 KB  (95.07 KB/s) 100 % - 0 s   
/var/lib/pkg/depot/gui/kwallet/.PKGR[14:25 x86_64 4.19.80-NuTyX-lts root@nutyx]
/var/lib/pkg/depot/gui/kwallet/kwallet1571498976x86_64.cards.tar.xz
    189.06 KB  (241.14 KB/s) 100 % - 0 s   
/var/lib/pkg/depot/gui/foomatic-db-engine/.PKGREPO
/var/lib/pkg/depot/gui/foomatic-db-engine/foomatic-db-engine1571478789x86_64.cards.tar.xz
    140.02 KB  (160.94 KB/s) 100 % - 0 s   
/var/lib/pkg/depot/gui/kemoticons/.P[14:25 x86_64 4.19.80-NuTyX-lts root@nutyx]
/var/lib/pkg/depot/gui/kemoticons/kemoticons1571498614x86_64.cards.tar.xz
     1.64 MB  (185.40 KB/s) 100 % - 0 s   
/var/lib/pkg/depot/gui/kidletime/.PKGREPO
/var/lib/pkg/depot/gui/kidletime/kidletime1571482809x86_64.cards.tar.xz
    28.34 KB  (44.98 KB/s) 100 % - 0 s   
/var/lib/pkg/depot/gui-extra/qbittorrent/.PKGREPO
HTTP response code said error
cards 2.4.103 install:

URL   : http://downloads.nutyx.org/x86_64/rolling/gui-extra/qbittorrent/.PKGREPO
FILE  : /var/lib/pkg/depot/gui-extra[14:25 x86_64 4.19.80-NuTyX-lts root@nutyx]
MD5SUM: aced1910cf0e43a98e9b74ffe78f83fc

 !!! download failed !!!

root [ / ]# cards sync
/var/lib/pkg/depot/desktops/.PKGREPO
/var/lib/pkg/depot/gui-extra/.PKGREPO
/var/lib/pkg/depot/gui/.PKGREPO
/var/lib/pkg/depot/cli-extra/.PKGREPO
/var/lib/pkg/depot/cli/.PKGREPO
/var/lib/pkg/depot/base/.PKGREPO
root [ / ]# get gui-extra
/var/lib/pkg/depot/gui-extra/qbittorrent/.PKGREPO
HTTP response code said error
cards 2.4.103 install:

URL   : http://downloads.nutyx.org/x86_64/rolling/gui-extra/qbittorrent/.PKGREPO
FILE  : /var/lib/pkg/depot/gui-extra/qbittorrent/.PKGREPO
MD5SUM: aced1910cf0e43a98e9b74ffe78f83fc

 !!! download failed !!!

[note that I just made sure LFS environment variable was set, and did #install-nutyx -ec to reenter my chroot... I did not do all the steps before to recreate the chroot...  ]

[I don't care about qbittorrent not installing, but I wish get gui-extra finish it's job of installing the others packages. Some kind of "get gui-extra --except qbittorrent" would be ok for me. cards not stopping on errors but doing as much it can do would be ok too. Sorry for insisting, as I know you are maintaining this distro almost alone -- hoping not to make angry to much other persons by saying this. ]
« Last Edit: Mon Oct 21 15:58:10 2019 by dufresnep »

Thierry

  • Administrator
  • Hero Member
  • *****
  • Posts: 595
  • Karma: +10/-0
  • Gender: Male
    • NuTyX distribution
Re: qbittorrent: binaries packages not generated
« Reply #3 on: Mon Oct 21 18:59:27 2019 »
 >:( >:( >:( >:(

Really sorry again. I don't know what I did now. anyway, you're right it's was not corrected. ....

Now it is : 8) 8) :o :o :P :P

I don't know what's your idea to make an iso with all gui-extra install. This collection is huge. So be aware:

Here is what I did for test very simple one just to give you an idea:
Code: [Select]
sudo install-nutyx
sudo install-nutyx -ec
check
get gui-extra

About 15/20 minutes later, I did check the number of package install (still no desktop included)
Code: [Select]
cards list|wc -l
839
means 839 install packages
 At leas we need lxde (it's the smallest one)
Code: [Select]
get lxde
.. ....
..
cards list|wc -l
853
Be aware that you will need to configure xorg-xdm  as explain in the doc.
don't forget to make:

Code: [Select]
cards purge
before you generate the squash files

If you make your own ISO You can also configure every thing  in the chroot via the command:
Code: [Select]
setup-nutyx -h
Good luck