Author Topic: run install-nutyx failure  (Read 1010 times)

dude2040

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
run install-nutyx failure
« on: Sun May 29 16:35:08 2022 »
Get this error when I run the shell script

pkgadd: dl-call-libc-early-init.c:37: _dl_call_libc_early_init: Assertion `sym != NULL' failed

Thierry

  • Administrator
  • Hero Member
  • *****
  • Posts: 644
  • Karma: +11/-0
  • Gender: Male
    • NuTyX distribution
Re: run install-nutyx failure
« Reply #1 on: Sun May 29 17:44:53 2022 »
Welcome on NuTyX forum.

About your issue. I guess you try to install NuTyX via another distribution.

This problem can not really solved. I did a lot of tests on differents distributions.
Not all accept the pkgadd command.

What's the name of the distribution you are trying from ?

Best regards,
Thierry

dude2040

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: run install-nutyx failure
« Reply #2 on: Mon May 30 09:49:17 2022 »
Hi Thierry,

Appreciate the reply.

I tried it with Ubuntu 18.02 on x86_64 and i686 platforms.  Due to missing libarchive I executed apt install libarchive-tools which fixed it.

When I tried it on my raspberry pi 4 with ubuntu 22.04 I got another error

variable PackageFileName is not set

umount: /mnt/hd/var/lib/pkg/depot: not mounted

I tried also with a live distribution void and got the libarchive error but persists despite installing it.

Is there a live distribution you can recommend?

dude2040

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: run install-nutyx failure
« Reply #3 on: Mon May 30 09:53:51 2022 »
When I said fix it I meant fixed the libarchive problem but still have the error I originally posted.

Thierry

  • Administrator
  • Hero Member
  • *****
  • Posts: 644
  • Karma: +11/-0
  • Gender: Male
    • NuTyX distribution
Re: run install-nutyx failure
« Reply #4 on: Mon May 30 18:36:06 2022 »