Author Topic: I would like to add a few Games  (Read 544 times)

BobC

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
I would like to add a few Games
« on: Sun Oct 01 04:02:16 2017 »
I am happy to report that I now have NuTyX 9.1 installed and running just fine on my Dell D620 laptop.  The performance is good, and I like the way that things are being installed.

I was able to add KDE's KMahjongg and KBreakout, which installed just fine with cards.

I would like to add Minesweeper, which is also available from KDE Games as kmines.  In the end, I made good progress, but couldn't fix a missing ECM package.  I had hoped that by copying kmahjongg's Pkgfile and bringing in kmines of the same version that I would avoid major problems.  If you could show me how to fix this game, I can try getting others packaged myself based on what I learn.  If kmines is too difficult, perhaps I could port in xdemineur which is not KDE dependent.

Thanks for creating NuTyX, and thanks for any help learning how to add packages...

I created a folder /usr/ports/kmines by copying the Pkgfile from kmahjongg at http://downloads.nutyx.org/x86_64/stable/kde5-extra/kmahjongg/Pkgfile and made a Pkgfile for kmines:

# Depends on : ?????  kf5-extra-cmake-modules kf5-kdoctools libkdegames hicolor-icon-theme

description="A Minesweeper-like game for KDE"
url="http://kde.org/applications/games/kmines/"
packager="b currey99 at yahoo dot com"
run=(xdg-utils)

name=kmines
version=16.12.3
release=1

source=(http://download.kde.org/Attic/applications/${version}/src/${name}-${version}.tar.xz)

build() {
mkdir -p build
cd build
cmake ../${name}-${version} \
    -DCMAKE_BUILD_TYPE=Release \
    -DBUILD_TESTING=OFF \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DCMAKE_INSTALL_LIBDIR=lib
make
make DESTDIR=$PKG install
}

At first I had trouble because cmake was missing, but after I installed cmake I only had an error on ECM remaining.  I fixed that eventually by installing kf5-extra-cmake-modules,  but now have an error on QT5 Widgets?

bobc [ /usr/ports/kmines ]$ sudo pkgmk -d
=======> PKGMK_INSTALL: no
=======> PKGMK_WORK_DIR: /usr/ports/kmines/work
=======> PKGMK_SOURCE_DIR: /usr/ports/kmines
=======> WARNING: CLEAN IGNORED
=======> PKGMK_IGNORE_REPO: yes
=======> PKGMK_IGNORE_FOOTPRINT: yes
=======> PKGMK_IGNORE_MD5SUM: yes
=======> .PKGREPO file will be deleted
=======> PKGMK_COMPRESS_PACKAGE: no
=======> name: kmines
=======> version: 16.12.3
=======> release: 1
=======> Building '/usr/ports/kmines/kmines1506836693x86_64.cards.tar.xz'.
bsdtar -p -o -C /usr/ports/kmines/work/src -xf /usr/ports/kmines/kmines-16.12.3.tar.xz
+ build
+ mkdir -p build
+ cd build
+ cmake ../kmines-16.12.3 -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTING=OFF -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
-- The C compiler identification is GNU 6.3.0
-- The CXX compiler identification is GNU 6.3.0                                                    [15:46 x86_64 4.9.23-NuTyX-lts bobc@nutyx]
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info                                                                   [15:46 x86_64 4.9.23-NuTyX-lts bobc@nutyx]
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at /usr/lib/cmake/Qt5Widgets/Qt5WidgetsConfig.cmake:27 (message):                      [15:46 x86_64 4.9.23-NuTyX-lts bobc@nutyx]
  The imported target "Qt5::Widgets" references the file

     "/usr/include/qt/"

  but this file does not exist.  Possible reasons include:

  * The file was deleted, renamed, or moved to another location.

  * An install or uninstall procedure did not complete successfully.

  * The installation package was faulty and contained

     "/usr/lib/cmake/Qt5Widgets/Qt5WidgetsConfig.cmake"

  but not all the files it references.                                                             [15:46 x86_64 4.9.23-NuTyX-lts bobc@nutyx]

Call Stack (most recent call first):
  /usr/lib/cmake/Qt5Widgets/Qt5WidgetsConfig.cmake:63 (_qt5_Widgets_check_file_exists)
  /usr/lib/cmake/Qt5/Qt5Config.cmake:28 (find_package)
  CMakeLists.txt:10 (find_package)


-- Configuring incomplete, errors occurred!
See also "/usr/ports/kmines/work/src/build/CMakeFiles/CMakeOutput.log".
=======> ERROR: Building '/usr/ports/kmines/kmines1506836693x86_64.cards.tar.xz' failed.
« Last Edit: Sun Oct 01 06:40:34 2017 by BobC »

BobC

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
Re: I would like to add a few Games
« Reply #1 on: Sun Oct 01 14:46:33 2017 »
I found someone else that had a similar problem and resolved it, but  I don't understand from it why I am having the problem or what I need to do to fix the problem I have.

https://stackoverflow.com/questions/18722329/cmake-does-not-find-qt-5-1-1

http://doc.qt.io/qt-5/cmake-manual.html