General > Cards: The Package Manager

cards freezes, not installing not upgrading

(1/2) > >>

fungalnet:
In the past few days when I run cards sync it seems to work fine.  When I run upgrade it begins downloading files, it seems as it completes the process and then just freezes, indefinitely.  No error message, cpu use shows active and continuous use 10-15%.
If I halt the process and start again with a simple install of a single pkg it does the same.

fungalnet:
running flcards from terminal opens up the gui, when I run sync it crashes

# flcards
--- Code: ---terminate called after throwing an instance of 'std::system_error'
  what():  Invalid argument
zsh: abort      flcards

--- End code ---
Thinking it may be related to zsh incompatibility I run it in bash


--- Code: ---# flcards
terminate called after throwing an instance of 'std::system_error'
  what():  Invalid argument
Aborted

--- End code ---


--- Code: ---# cards sync
/var/lib/pkg/depot/nos/.PKGREPO
/var/lib/pkg/depot/lxde-extra/.PKGREPO
/var/lib/pkg/depot/lxde/.PKGREPO
/var/lib/pkg/depot/xfce4-extra/.PKGREPO
/var/lib/pkg/depot/xfce4/.PKGREPO
/var/lib/pkg/depot/gui-extra/.PKGREPO
/var/lib/pkg/depot/gui/.PKGREPO
/var/lib/pkg/depot/cli-extra/.PKGREPO
/var/lib/pkg/depot/cli/.PKGREPO
/var/lib/pkg/depot/base/.PKGREPO
root [ ~ ]# cards upgrade
Retrieve info about the 377 packages:  83%
--- End code ---

Then it stays like this indefinitely, no error produced, and I couldn't find any log for cards yet

Another example:

--- Code: ---# cards install git
/var/lib/pkg/depot/base/git/.PKGREPO
/var/lib/pkg/depot/base/git/git1539112741x86_64.cards.tar.xz
     3.11 MB  (357.82 KB/s) 100 % - 0 s   
/var/lib/pkg/depot/base/openssh/.PKGREPO
/var/lib/pkg/depot/base/openssh/openssh1535278479x86_64.cards.tar.xz
    659.60 KB  (258.97 KB/s) 100 % - 0 s   
/var/lib/pkg/depot/base/libedit/.PKGREPO
/var/lib/pkg/depot/base/libedit/libedit1533484375x86_64.cards.tar.xz
    118.63 KB  (129.65 KB/s) 100 % - 0 s   
Retrieve info about the 377 packages:  83%

--- End code ---

oyim:
I've not tried running it via the terminal; however, I have had it crash a couple of times when running Sync. I realized that if I run Sync before all of the packages populate the window, that's when it would crash. If I allow them to populate first, then run Sync, I haven't had any issues.

fungalnet:
cards sync on terminal runs fine, it is during installation or upgrade that it freezes, after the downloading has completed it seems.
That 83% that is pretty constant I think it is the last thing it reports before completion, not that it is incomplete.

Thierry:
Can I see your /etc/cards.conf file. I beleave you comment some collections AFTER you install packages that are not  in any collection you have at the moment.

Regards,
Thierry

Navigation

[0] Message Index

[#] Next page

Go to full version