Author Topic: generate iso: mkiso: It's not the 5.3.7-NuTyX kernel in this ISO  (Read 36 times)

dufresnep

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
When I came to generate the iso, I got:
(yeah, I had forgotten to set export NUTYX_TMP=/mnt/nutyx_tmp so that stuff ended in my home directory)
Code: [Select]
root [ /home/paul/packages-x86_64/x86_64 ]
# bash rolling/scripts/mkiso
something went wrong: It's not the 5.3.7-NuTyX kernel in this ISO

root [ /home/paul/packages-x86_64/x86_64 ]# ls $LFS
bin   dev  home  language.check  lib64         mnt  pkg   root  sbin  sys  usr
boot  etc  ISO   lib             locale.check  opt  proc  run   srv   tmp  var

root [ /home/paul/packages-x86_64/x86_64 ]# ls $LFS/boot
config_64-4.19.80-NuTyX-lts  kernel-4.19.80-NuTyX-lts
grub                         kernel-lts
initrd-4.19.80-NuTyX-lts     System_64.map-4.19.80-NuTyX-lts
root [ /home/paul/packages-x86_64/x86_64 ]#

indeed, it seems to be 4.19.80, not 5.3.7 kernel... is it really wrong?
« Last Edit: Mon Oct 21 22:27:00 2019 by dufresnep »

oyim

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +2/-0
Re: generate iso: mkiso: It's not the 5.3.7-NuTyX kernel in this ISO
« Reply #1 on: Tue Oct 22 00:27:46 2019 »
Until Thierry answers, you may see if this helps...

https://forums.nutyx.org/index.php/topic,349.msg1183.html#msg1183

dufresnep

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: generate iso: mkiso: It's not the 5.3.7-NuTyX kernel in this ISO
« Reply #2 on: Tue Oct 22 04:48:05 2019 »
I redone bash mkiso, without any pararmeters and it worked fine this time.

That said, the almost 6 Gib, refuse to be copied in my 4 Gb ram when I try to boot it.
Don't know if there is an option to tell to mount the different squashfs files rather than try to copy them in ram.
« Last Edit: Tue Oct 22 05:04:39 2019 by dufresnep »

Thierry

  • Administrator
  • Sr. Member
  • *****
  • Posts: 490
  • Karma: +7/-0
  • Gender: Male
    • NuTyX distribution
Re: generate iso: mkiso: It's not the 5.3.7-NuTyX kernel in this ISO
« Reply #3 on: Tue Oct 22 06:56:58 2019 »
when you get:
Code: [Select]
# bash rolling/scripts/mkiso
something went wrong: It's not the 5.3.7-NuTyX kernel in this ISO

You should use pass the kernel name as second parameter like explain in the help:
Code: [Select]
bash rolling/scripts/mkiso -h
So then you will need to pass param1 as well like this:

Code: [Select]
bash rolling/scripts/mkiso 20191022 $(basename $LFS/lib/modules/*)