Help > Cards: The Package Manager

depcreate abiword: lot of files not found followed by segmentation error

<< < (2/2)

Forgot to tell you what your mistake in the configuration Cards.conf file: You forgot to Change the directories where all the ports are located.

/var/lib/pkg/depot -> /usr/ports

Live System has nothing todo with this issue.

It is now compiling...

hum... cmake is not happy:

--- Code: ----- Looking for a Fortran compiler
-- Looking for a Fortran compiler - /usr/bin/gfortran
CMake Error at /usr/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:27 (message):
  The imported target "Qt5::Core" references the file


  but this file does not exist.  Possible reasons include:

  * The file was deleted, renamed, or moved to another location.

  * An install or uninstall procedure did not complete successfully.

  * The installation package was faulty and contained


  but not all the files it references.

Call Stack (most recent call first):
  /usr/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:74 (_qt5_Core_check_file_exists)
  Tests/RunCMake/CMakeLists.txt:337 (find_package)

-- Configuring incomplete, errors occurred!
See also "/usr/ports/cli/cmake/work/src/cmake-3.15.4/CMakeFiles/CMakeOutput.log"
--- End code ---

but it is going much farther.

The "cards depcreate" command assume you have all the devel packages group installed as well for all the packages that you actualy have  installed. So the easiest way you add: "group devel" into your /etc/cards.conf file and then you do a "sudo cards upgrade". If you are not happy with this approach they are many others. But you will need to read more

- Scenario A, B, C, D or E

- And the ultimate weapon for the end: The Build-Bot

Well... I did take a look to the scenarios... but I wanted to continue to do things 'the wrong way' a little bit more before doing the 'right thing'.

So I have now:
paul [ /usr/ports/cli/cyrus-sasl ]$ cards config
1 Dossier:  /usr/ports/gui-extra
2 Dossier:  /usr/ports/gui
3 Dossier:  /usr/ports/cli
4 Dossier:  /usr/ports/cli-extra
5 Dossier:  /usr/ports/base
6 Dossier:  /usr/ports/desktops
Liste des dossiers pour le système de base: /usr/ports/base
Binaires : x86_64
Group    : devel
Group    : man
Group    : fr
paul [ /usr/ports/cli/cyrus-sasl ]$

But I have this line that I had uncommented before:

When trying to cards depcreate abiword, I was having the same missing Pkgfiles, and segmentation faults as before.

So I decided to go the cowboy way:
sudo cards base

And then, I had to get mate... firefox, etc.
I then realized that I also needed: mate-extra
But It seems that most of mate packages was not reinstalled by default.
e.g. I realized I was not having the window-manager for mate: marco , and get it manually.
So I begin to doubt that the new package set really works with get.

I finally seen that sudo depcreate abiword, when the #url line was uncommented, resulted in
it trying to 'install' one of the missing dependency, but says that the package does not exist.
So I made a cycle of get dependency, cards depcreate abiword, until I get to the latest one: abiword.
So the system was saying abiword does not exist... so I just continue and done the stupid thing: get abiword.
So at this step, I had the binary package of abiword installed, but not by compiling the port.

So I did: sudo remove abiword. Also commented back the #url line in /etc/cards.conf.
But then, sudo depcreate abiword was complaining some binary packages needed to be remove: abiword-devel... and an other like this, maybe abiword-fr... don't remember clearly.
I tried sudo cards purge I think, but did not seems to do any good.

So I ended to manually remove the .tar files in /usr/ports/gui-extra/abiword ... or was it the work directory in that directory... anyway that fixed it.

Still unsure, but to me it seems cards remove just remove the main package, not the sub-packages... as I was expecting.

So that finally, sudo depcreate abiword worked!

I tried other: sudo depcreate ocaml (strange it is in gui-extra).
paul [ /usr/ports/gui-extra/ocaml ]$ ocaml -version
The OCaml toplevel, version 4.06.0
paul [ /usr/ports/gui-extra/ocaml ]$
btw, 4.09 is the current version.

Then tried cards depcreate qemu:
paul [ /usr/ports/gui-extra/ocaml ]$ sudo cards depcreate qemu
create of cyrus-sasl
cards create: /usr/ports/cli/cyrus-sasl package(s)
=======> Downloading ''.
=======> Partial download found, trying to resume
--2019-10-24 20:38:50--
           => '/usr/ports/cli/cyrus-sasl/cyrus-sasl-2.1.27.tar.gz.partial'
Connecting to||:21...

Never was able to finish the download.
Could it be build from: ?


[0] Message Index

[*] Previous page

Go to full version