Help > Installation

run install-nutyx failure


Get this error when I run the shell script

pkgadd: dl-call-libc-early-init.c:37: _dl_call_libc_early_init: Assertion `sym != NULL' failed

Welcome on NuTyX forum.

About your issue. I guess you try to install NuTyX via another distribution.

This problem can not really solved. I did a lot of tests on differents distributions.
Not all accept the pkgadd command.

What's the name of the distribution you are trying from ?

Best regards,

Hi Thierry,

Appreciate the reply.

I tried it with Ubuntu 18.02 on x86_64 and i686 platforms.  Due to missing libarchive I executed apt install libarchive-tools which fixed it.

When I tried it on my raspberry pi 4 with ubuntu 22.04 I got another error

variable PackageFileName is not set

umount: /mnt/hd/var/lib/pkg/depot: not mounted

I tried also with a live distribution void and got the libarchive error but persists despite installing it.

Is there a live distribution you can recommend?

When I said fix it I meant fixed the libarchive problem but still have the error I originally posted.

Any ISO are live compatible, means you can use the tutorial on the documentation to install NuTyX in full manual mode via install-nutyx.

Good luck



[0] Message Index

Go to full version