Help > General

How to remove pulseaudio and how to mount partitions with gui

(1/3) > >>

Hello, I'd like to have system without pulseaudio.
 I wonder why is pulseaudio default along with MPV, should we have some freedom to choose ?
 Tried to uninstall from terminal without gui "pulseaudio is in use".

 I can't mount partitions. Some of them are xfce4, some of them are ntfs.

 Istalled fuse, fuse2, gvfs, ntfs-3g.

 Mounting works fine with terminal, but not with gui.
 I can't restart or shutdown with XFCE, only with terminal.

 Thank you.

Hi Dj

Which Desktop are you using ?
That leads to which gui are you trying to mount partitions with? Mine are all mount on boot "Gnome"

--- Quote --- I can't restart or shutdown with XFCE, only with terminal.
--- End quote ---
I tested XFCE4 works ok here, hmmm.
pulseaudio might be  a dep of some packages

Hello, I have been using XFCE.

I hope spiky does not mind my 2 cents worth.

--- Quote ---I can't restart or shutdown with XFCE
--- End quote ---
what display manager (login manager) are you using?
On IceWM, I installed lightdm...modified my /etc/inittab to change the line for xdm* so it reads

--- Quote ---x:5:respawn:/usr/bin/lightdm
--- End quote ---

You may have to edit /etc/lightdm/lightdm.conf....but I have not.

I can click the icewm exit menu -> takes me to login screen and top RH corner is a power icon to
restart or shutdown.

2) there is a way of running pkexec <command> but lets keep it simple?

--- Quote ---pulseaudio is in use
--- End quote ---
I have a different remove command with similar report.....but on your distro, its possible pulseaudio has been
autostarted or respawned.....and won't allow deletion until that process is killed or daemon stopped.

If you have what you see on normal boot up for these commands, run as local user

--- Code: ---ps -e | grep pulseaudio

pacmd list-sinks
--- End code ---

I do not have pulseaudio installed so I get no hits....and the last command gives me
No PulseAudio daemon running, or not running as session daemon

leaping ahead....if you find it running, I would suggest delete the /etc/init.d/< daemon name>
 likely to be pulseaudio reboot and then attempt delete command YMMV

I did a clean install of xfce4, All linux partitions (ext4) are shown on Desktop and all mount using Thunar. Yes Ntfs not mounting ?.

Pulseaudio is not pulled in on xfce4, Firefox pulls it in as a dep.
Xfce4-extra pulls in xfce4-pulseaudio-plugin, as part of a collection, removeable.

MPV is not pulled in with either Xfce4 or extra

As for Shutdown Reboot xfce4, it dose work. If you have tried to mount the Ntfs that blocks it, reboot, as long as ntfs is not in fstab shutdown reboot works.


[0] Message Index

[#] Next page

Go to full version