Author Topic: DKMS and Linux Kernel Headers  (Read 931 times)

ndawka

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
DKMS and Linux Kernel Headers
« on: Sun Sep 18 06:38:09 2022 »
Hello!

I have been trying to install EVDI, that requires both DKMS and Linux Kernel Headers. DKMS isn't too much of a problem, it is possible, to compile DKMS from source. What needs to be done with kernel headers? Since NuTyX is rolling release, it would be very difficult to install headers for the kernel upon each update. Is there a way to install some kernel headers package, or similar?

This is the error, that I specifically get:
Quote
Creating symlink /var/lib/dkms/evdi/1.12.0/source -> /usr/src/evdi-1.12.0
Error! Your kernel headers for kernel 5.19.8-NuTyX cannot be found at /lib/modules/5.19.8-NuTyX/build or /lib/modules/5.19.8-NuTyX/source.
Please install the linux-headers-5.19.8-NuTyX package or use the --kernelsourcedir option to tell DKMS where it's located.
Deleting module evdi-1.12.0 completely from the DKMS tree.
ERROR: Failed to install evdi to the kernel tree.

Thierry

  • Administrator
  • Hero Member
  • *****
  • Posts: 649
  • Karma: +12/-0
  • Gender: Male
    • NuTyX distribution
Re: DKMS and Linux Kernel Headers
« Reply #1 on: Mon Sep 19 09:34:30 2022 »
Install the kernel headers via the kernel.devel package. You will probably need cards.devel as well. Some more might be needed. Repeat the command with the package required:

Code: [Select]
sudo cards install cards.devel kernel.devel
Quote
Since NuTyX is rolling release, it would be very difficult to install headers for the kernel upon each update
Don't worry about it, ones they are installed, they will be updated together with your kernel.

Best regards
Thierry