Help > General

Tor evutil_secure_rng_add_bytes Error


I have just installed a fresh copy of NuTyX 22.12. I have updated it and restarted the system. I have then installed Tor from the NuTyX repository.

Tor installed fine. But when running it (tor, tor --version, etc.) I get an error:

--- Quote ---tor: symbol lookup error: tor: undefined symbol: evutil_secure_rng_add_bytes
--- End quote ---

I have tried restarting the system, reinstalling it, reinstalling it after changing my init system to systemd ( Nothing worked. I keep getting the same error.

I have looked up this error and found, that multiple people had this exact error on BSD-based systems. Their problem was erroneous libevent. I have installed both libevent and libevent.devel (libevent was reinstalled with 4 additional files). Restarted the system. That did not help.

Now I have realised, that
--- Code: ---sudo systemctl status tor
--- End code ---
--- Quote ---Unit tor.service could not be found.
--- End quote ---
and running
--- Code: ---ss | grep 9050
--- End code ---
(9050 is the default Tor port) returns nothing. I have even run
--- Code: ---ss
--- End code ---
to see, if Tor occupied a different port, but it is nowhere to be seen.

I am lost right now. I was planning to build Tor from source, but I am not sure, if I am missing something. Is it possible to fix this error without installing Tor from source?

I think, this is the Tor repository:

Best Regards!

Hello ndawka

I will look at it as soon I can.

Thanks a lot for reporting


Also, I think there is some version mistake going on. Apparently, Tor was committed last month (, but is still listed as Tor  :o

Version is indeed listed as in, so that probably is linked to the issue, since Tor is listed as and is also installed as

Fixed at version

Sorry for the inconvenience



[0] Message Index

Go to full version