Author Topic: Evolution error  (Read 965 times)

PrimeSuspect

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Evolution error
« on: Thu Mar 02 07:41:04 2023 »
For various reasons I need to use Evolution as my mail client although I prefer the KDE desktop. This hasn't been an issue until I just installed the KDE version of 23.02.01. As normal I made sure the new system was up to date then installed Evolution using Cards. I use two accounts, one Gmail and one GMX both setup as POP. The GMX account is fine but the Gmail account returns an error.

"Failed to authenticate on POP server pop.gmail.com: createDLGroup failed: maybe libqca-ossl is missing"

Any help to resolve this would be greatly appreciated.

Thunderbird is not an option since I need to see a permanent notification for unread mail, Birdtray is not available for NuTyX and unless something has changed it doesn't work anyway with the latest version of Thunderbird.

Thierry

  • Administrator
  • Hero Member
  • *****
  • Posts: 694
  • Karma: +13/-0
  • Gender: Male
    • NuTyX distribution
Re: Evolution error
« Reply #1 on: Thu Mar 02 07:55:56 2023 »
Will have a look
Birdtray seems to be very old version. (2020)

PrimeSuspect

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Evolution error
« Reply #2 on: Thu Mar 02 10:41:02 2023 »
Thanks.

Yes, I don't think Birdtray is being maintained any more and to my knowledge stopped working with all functions after Thunderbird 91.

I've seen some posts relating this to an issue with Wayland although the suggested fixes are complicated and the results very hit and miss. I guess the solution is for another developer to pick up the code and re-write it although I appreciate this might involve a lot of work for the potentially small group of users it might benefit.

Fixing Evolution would be my wish.

PrimeSuspect

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Evolution error
« Reply #3 on: Thu Mar 02 12:54:26 2023 »
Have subsequently found that Evolution is not remembering the GMX password and asks for it every time.

Thierry

  • Administrator
  • Hero Member
  • *****
  • Posts: 694
  • Karma: +13/-0
  • Gender: Male
    • NuTyX distribution
Re: Evolution error
« Reply #4 on: Thu Mar 02 13:22:02 2023 »
Make sure gnome-keyring is installed

PrimeSuspect

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Evolution error
« Reply #5 on: Thu Mar 02 15:41:41 2023 »
Yes, but I had already done that.

Thierry

  • Administrator
  • Hero Member
  • *****
  • Posts: 694
  • Karma: +13/-0
  • Gender: Male
    • NuTyX distribution
Re: Evolution error
« Reply #6 on: Thu Mar 02 18:00:15 2023 »
What do you see as output on the console when you start evolution from the console.?

Is gnome-keyring-daemon running ?

PrimeSuspect

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Evolution error
« Reply #7 on: Fri Mar 03 07:39:59 2023 »
There is no output in the terminal on start. Evolution just starts as normal. Closing it again though generates this in terminal.

(evolution:2215): GLib-GIO-WARNING **: 04:32:06.332: Your application did not unregister from D-Bus before destruction. Consider using g_application_run().

On checking, no I can`t see the gnome-keyring-daemon running in the list of services so guess this seems to be where the problem lies.

Entering that as a command in terminal generates this.

gnome-keyring-daemon: no process capabilities, insecure memory might get used
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh

PrimeSuspect

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Evolution error
« Reply #8 on: Fri Mar 03 11:59:04 2023 »
In the meantime I`ve found an acceptable solution. Installing the Flatpak version of Betterbird works since this DOES have a tray notification for new mail and it works with the KDE desktop.