Author Topic: Nutyx on Mac hardware  (Read 2756 times)


  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Nutyx on Mac hardware
« on: Wed Sep 13 05:19:56 2023 »
Hello everyone

First off, fantastic distro. It's super speedy, cards is a great package manager also.

So right to the crux of my problem -- as per the title I am using Nutyx on Mac hardware, more specifically a MacBook Pro A1278, from 2012.
The Apple EFI usually plays well with Linux, with some exceptions Nutyx unfortunately being one of them.
The install itself goes well, with the exception of the bootloader, but I can boot in the installed system post-install.
I tried the option in Advanced to configure the bootloader but this fails and drops me in a shell.
So no big deal, I'll reinstall, boot in the system and fix it myself.
Just to be sure, I mount /dev/sda1 to /boot, then install GRUB via cards.
Due to this quirky EFI, I used grub-install --target=x86_64-efi --efi-directory=/boot --removable to install GRUB, and then grub-mkconfig -o /boot/grub/grub.cfg.
Both steps complete without errors but GRUB does not find any Linux image.
On reboot I am greeted by the file folder with a question mark on it, aka No OS found.
The Nutyx documentation says to install efibootmgr. It works, but returns "EFI variables are not supported on this system".
After some research, I found that maybe the module is simply not loaded, and that doing modprobe efivarfs could fix it.
So then I turned to rEFInd, and has the same EFI variables not supported issue.
I spent the evening tinkering with it, to no avail and I am a bit at a loss.
Any other Mac users amongst us? Or am I the lone nutcase? 🤣
I just love this old Mac.


  • Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
Re: Nutyx on Mac hardware
« Reply #1 on: Sun Nov 19 12:55:36 2023 »
You can try a couple of solutions, as per

First, please check, that the efivar package is installed using
Code: [Select]
sudo cards install efivar. Then:

Check that UEFI boot method is set as default.

Code: [Select]
mount --bind /sys/firmware/efi/efivars /mnt/sys/firmware/efi/efivars before chrooting.

Switch over to systemd using this guide:, then enable efivars using
Code: [Select]
sudo modprobe efivarfs, after that try chrooting into the system and
Code: [Select]
grub install again.

Add efi=runtime to your kernel parameters in /etc/default/grub configuration.

Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="efi=runtime quiet" (or whatever the default is on NuTyX and add "efi=runtime")
Don't forget
Code: [Select]
sudo update-grub2!