Official NuTyX forums

Documentation => ISOs, initrd, initramfs => Topic started by: BobC on Wed Apr 12 08:07:15 2017

Title: Initial boot problem with 9.0 on USB
Post by: BobC on Wed Apr 12 08:07:15 2017
I downloaded the x86_64 version and made a flash drive with dd.  I put it in my Dell Inspiron 15 7559 laptop with nVidia GTX 960, 16gb memory and 256 Micron SSD, and 1TB hard drive, and with secure UEFI turned off, I reboot.  I do F12 for boot options, select the UEFI USB and NutYx grub menu comes up.  If i type an e, remove quiet and F10 to boot, it tries to boot and the screen says booting a command list, then goes black and then the computer reboots.  The debug boot option does the same thing.

I do have AntiX running on this same machine with a 4.10.1 Kernel.

Do you have any ideas what to try or is there a list of boot cheat codes?

Thanks for any ideas or help...
Title: Re: Initial boot problem with 9.0 on USB
Post by: Thierry on Wed Apr 12 08:45:14 2017
Try to add
Code: [Select]
pci=nocrs pci=norealloc
at grub line when you boot on the UEFI version of the ISO.
Title: Re: Initial boot problem with 9.0 on USB
Post by: fanch on Wed Apr 12 12:44:23 2017
I use a fixed PC ASUS ROG G20 -Intel (R) Core (TM) i7-4790 CPU @ 3.60GHz - NVIDIA GTX 970 - 8000 ram with of course a bios uefi. This PC comes with Windows 10 by default. 8)

At first, I replaced the hard drive to put an equivalent but blank disk. To use NuTyX, bios version, I have to modify the settings of the dedicated bios by default to windows 10. In summary, I put in the drop-down menu Other OS in place of Windows. From there I was able to install the BIOS version of NUTYX with a serious problem, I could only use kernels 4.4.x. I was therefore unable to run a kernel 4.9 or 4.10. At the time, Tnut did not fully grasp the problem and had no real solutions to propose to me. The time to go and the demand for UEFI has begun to become more and more pressing.  :P

Secondly, Tnut offered to test its NuTyX iso. To make it simple, I told him that no UEFI distribution was installed. I tested archlinux, archanywhere, manjaro, mint with 4.4, opensuse, ubuntu gnome etc. I have to say that I have had more disappointments and failures. :D
Tnut imperturbable told me, I would not let you go before it works on your PC. I agree but I tell you frankly, I did not believe it.

Third time, I test the iso of Tnut. Before launching them, I go through the bios and I note that the iso is recognized in BIOS version and in UEFI version. There was nothing new, the others were recognized in the same way. I continue and boot by choosing the UEFI version. It launches without problem and I arrive on the interface. I type as indicated (take the time to read what appears on the screen) "-ec" and I end up with the possibility of commanding and modifying and adding certain functions.
Tnut asks me to add after ... ... ro quiet pci = nocrs pci = norealloc. Then I am what is written at the bottom of the screen and boot without problem on the NuTyX installation in UEFI. :P

Fourthly, the NuTyX iso UEFI is operational. You now have to install NuTyX in UEFI. You will believe me if you want but the suite is ultra simple. The only difficulty is to partition your hard drive into GPT.
We'll do the simplest. :

1 / you go into partitioning. You choose fdisk and then the help key is 'm'. You read and choose 'g' as GPT then you save it all with 'w'.
2 / you switch to cfdisk, it will be more visual. You create at least three partitions.
--the BOOT partition: size about 300 MB and especially in TYPE, you define it as partition system UEFI
-a SWAP partition (for size, you are free from 1 to 4 GB), it should go. Swap partition type.
-To finish, one or two system partitions is / and personal / home. I leave you free, do not forget to mention the TYPE of the score.
You write by typing yes and exit cfdisk.
3 / Back in the installation interface, you format. I put BTFRS on INFO.
4 / You Install, if you are not in GPT, you will get an error message.

The usual process of your NuTyX follows its path. You log in and password and you arrive immediately at the end of your installation.

Frankly, it's really too simple to install in UEFI with NuTyX. It's a bit of a problem at first but it's a disconcerting simplicity.

Title: Re: Initial boot problem with 9.0 on USB
Post by: BobC on Thu Apr 13 05:53:13 2017
Thanks for the replies. 

I tried the boot cheat codes, but the result was the same. 

I don't really want to replace the drive if I can avoid it. 

I did make a Windows 10 restore USB flash drive just in case I make a mess so I can restore if I need to.  My live data is still on my old machine, so the new machine is experimental.  AntiX  works, so I'm using it to control Grub.

I was finally able to boot using the Legacy boot options: USB Storage Device, and get the install screens.  My characters are very tiny due to my 3840x2160 graphics, so I had to wear reading glasses and use a 5 x magnifer to read the words on the screen.  I made it through the install and installed xorg, xfce4, slim and most other packages shown on the instructions.

My problem at the moment is that X doesn't start when I type
startx  xfce4

it replies

xauth: file /home/bobc/.serverauth.1025 does not exist

waiting for X server to begin accepting connections .

Do I need to create or configure some things to get xorg and xfce4 to run, or is there something wrong?  Could you please point me to an example or instructions if you can.

Also, If you know a way to change the console screen resolution to something more readable like 1440x900 or 1280x1024 or 1920x1080 it would be appreciated.

By the way, Thanks much for creating this.  I've always been interested in LFS and this seems more doable than doing EVERYTHING from scratch, which I sure was a big learning adventure.

Title: Re: Initial boot problem with 9.0 on USB
Post by: Thierry on Thu Apr 13 06:55:17 2017
About your problem of starting X server and Xfce4. I think if you do:

Code: [Select]
del slim
get lxdm

And after reboot, you should have the lxdm login manager and just need to choose XFCE in the left menu and your're done
Title: Re: Initial boot problem with 9.0 on USB
Post by: BobC on Thu Apr 13 08:11:55 2017
Thanks for the quick reply.  It looked like it deleted slim and installed lvdm ok, but after a reboot it goes to a black screen with blinking cursor.

I have to Ctrl-Alt-F4 to get to a console login.

I didn't find a log for Xorg in /var/log

Any ideas?  Can I try running it in VESA graphics mode?
Title: Re: Initial boot problem with 9.0 on USB
Post by: Thierry on Thu Apr 13 08:31:25 2017
It look like you have something wrong in your profile or in your /etc/lxdm/lxdm.conf

Can you post here the content of your  /etc/lxdm/lxdm.conf
Title: Re: Initial boot problem with 9.0 on USB
Post by: BobC on Thu Apr 13 09:20:22 2017
Thanks for the quick reply again.  Here is the file.  I'm sorry, I'm not familiar with lxdm.

## uncomment and set autologin username to enable autologin
# autologin=bobc

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10

## default session or desktop used when no systemwide config
# session=/usr/bin/startxfce4

## uncomment and set to set numlock on your keyboard
# numlock=0

## set this if you don't want to put xauth file at ~/.Xauthority
# xauth_path=/tmp

# not ask password for users who have empty password
# skip_password=1

## greeter used to welcome the user

## arg used to start xserver, not fully function
# arg=/usr/bin/X -background vt1
# uncomment this if you really want xserver listen to tcp
# tcp_listen=1
# uncoment this if you want reset the xserver after logout

## gtk theme used by greeter

## background of the greeter

## if show bottom pane

## if show language select control

## if show keyboard layout select control

## the theme of greeter


## if disable the user list control at greeter

## whitelist user

## blacklist user
Title: Re: Initial boot problem with 9.0 on USB
Post by: BobC on Sat Apr 15 19:29:25 2017
fanch,  At this point I think I'm installed, and my machine is quite similar, graphics and cpu, but can't get lxdm to run, because I don't see any log from Xorg, so therefore it never gets that far.

My guess would be the fancy graphics on my machine aren't working right with lxdm.

I don't know if there are any logs or clues left behind, but I've run out of ideas otherwise, and don't know what calls lxdm or how.

Thanks for everyone's help, maybe I should try it on a simpler machine.

Title: Re: Initial boot problem with 9.0 on USB
Post by: Thierry on Sat Apr 15 20:38:25 2017
Here are the logs you could check:

Code: [Select]
sudo more /var/log/lxdm.log
more /var/log/Xorg.0.log
Title: Re: Initial boot problem with 9.0 on USB
Post by: BobC on Sun Apr 16 03:04:16 2017
I reinstalled, this time with lxdm not slim, and got a login screen this time.  I had trouble getting X running, but found a kernel cheat code that fixed it for a Dell Inspiron 15 7559 laptop. 

GRUB_CMDLINE_LINUX_DEFAULT="ro acpi_osi='!Windows 2015' i915.preliminary_hw_support=1"

I am running the grub from AntiX so I have to build it into /etc/grub.d/40_custom

I then couldn't connect with my WiFi anymore, and network manager says it is connected, but immediately disconnects.  I will look to see if I can find a different WiFi manager.  Ceni and Frisbee are ones I've used before, also WiCd, as well as by hand (not recently).  Its strange that it worked for the install and then didn't work anymore when I got to X.

I also have no suspend option on the logout menu or power manager, but that could be an Xfce4 issue or maybe its related to the acpi.

I'm probable going to try another try at reloading, not sure which desktop to try instead of Xfce4.

Any ideas on what wifi manager programs are available and what desktop might allow suspend?
Title: Re: Initial boot problem with 9.0 on USB
Post by: Thierry on Sun Apr 16 12:02:55 2017
Any ideas on what wifi manager programs are available and what desktop might allow suspend?
You need to install pm-utils to be able to suspend you XFCE4 session

About Wireless tools, we have three possibilities:

- cli
- networkmanager
- wicd

You should install networkmanager or wicd if the cli do not satify your requests, then you should adjust the variable MANAGER in the /etc/sysconfig/network file, more info: