Recent Posts

Pages: [1] 2 3 ... 10
General / Re: Problem with installing anrysearch and fsearch
« Last post by Dj on Thu Jan 19 19:09:24 2023 »
Fsearch is in flatpak, in case someone is interested.
General / Re: AMD Ryzen and cpupower
« Last post by Dj on Thu Jan 19 19:07:12 2023 »
In case someone is interested - TLP is blocking CPU frequency, so with installed TLP, Cpu is 2ghz instead of 4 ghz. Only way that I found is to disable TLP.
General / Re: Need Wifi and/or dependency of AppImages
« Last post by surimelow on Tue Jan 17 00:38:36 2023 »
Hello and thank you for your time.

I've decided to try again and install with a different desktop environment, with KDE. I am writing from the new installation.  :D

Wifi works but the obligated KWallet is very annoying. The system settings doesn't seem to have a way to disable it. I might have to type in my modem password everytime I start this system. It's better than nothing. "cards" works. I have updated the system to kernel v6.0.19 and other things. Installed the library needed to play AppImages.

I knew there was a way to get Wifi going on XFCE but I'm not even Linux intermediate.

Cheers for having a simple straightforward distro installation routine. Although it might help if UUID's were recognized because "/dev/sda2" and such could be unreliable. Cool "neofetch" symbol! Although on my screen it displays in blue, I noticed the Nutyx logo is red with black shield. First found out about the distro on Distrowatch.

Again, thank you for your prompt response and your time in answering me.
General / Re: Tor evutil_secure_rng_add_bytes Error
« Last post by Thierry on Fri Jan 13 08:08:47 2023 »
Fixed at version

Sorry for the inconvenience


General / Re: AMD Ryzen and cpupower
« Last post by Dj on Tue Jan 10 12:42:30 2023 »
Since there is no cpupower, I have been using tlp. Active governor is shedutil
/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver    = amd-pstate
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = schedutil
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors = conservative performance schedutil
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =   400000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  2100000 [kHz]
Тhere is no accurate reading of cpu, it's showing max frequency of 2. ghz.
 How to change cpufreq governor ?
General / Re: Tor evutil_secure_rng_add_bytes Error
« Last post by ndawka on Mon Jan 09 13:27:25 2023 »
Also, I think there is some version mistake going on. Apparently, Tor was committed last month (, but is still listed as Tor

Version is indeed listed as in, so that probably is linked to the issue, since Tor is listed as and is also installed as
General / Re: Tor evutil_secure_rng_add_bytes Error
« Last post by Thierry on Mon Jan 09 10:15:03 2023 »
Hello ndawka

I will look at it as soon I can.

Thanks a lot for reporting

General / Tor evutil_secure_rng_add_bytes Error
« Last post by ndawka on Mon Jan 09 00:21:08 2023 »
I have just installed a fresh copy of NuTyX 22.12. I have updated it and restarted the system. I have then installed Tor from the NuTyX repository.

Tor installed fine. But when running it (tor, tor --version, etc.) I get an error:
tor: symbol lookup error: tor: undefined symbol: evutil_secure_rng_add_bytes

I have tried restarting the system, reinstalling it, reinstalling it after changing my init system to systemd ( Nothing worked. I keep getting the same error.

I have looked up this error and found, that multiple people had this exact error on BSD-based systems. Their problem was erroneous libevent. I have installed both libevent and libevent.devel (libevent was reinstalled with 4 additional files). Restarted the system. That did not help.

Now I have realised, that
Code: [Select]
sudo systemctl status tor returns
Unit tor.service could not be found.
and running
Code: [Select]
ss | grep 9050 (9050 is the default Tor port) returns nothing. I have even run
Code: [Select]
ss to see, if Tor occupied a different port, but it is nowhere to be seen.

I am lost right now. I was planning to build Tor from source, but I am not sure, if I am missing something. Is it possible to fix this error without installing Tor from source?

I think, this is the Tor repository:

Best Regards!
General / Re: Powertop
« Last post by Dj on Sat Jan 07 14:08:17 2023 »
It seems that I had to restart. Now it works.
 Can anyone clarify why blocking acpi-cpufreq is blocking powertop ?
General / Powertop
« Last post by Dj on Sat Jan 07 09:04:12 2023 »
sudo powertop

C-state information is not available     [09:53 x86_64 6.0.17-NuTyX root@linux]

Wakeups-from-idle in 10 seconds: 0

powertop: no stats available; run as root or enable the timer_stats module

modprobe timer_stats
modprobe: module timer_stats not found in modules.dep
After blacklisting of acpi-cpupower AMD system is working fine. But why I can't start powertop ?

Un-blacklist acpi-cpufreq. Still does not work.
Pages: [1] 2 3 ... 10