Recent Posts

Pages: 1 [2] 3 4 ... 10
General / Re: Lxqt is broken
« Last post by pupuklok on Sat Sep 23 12:00:57 2023 »
Hi Thierry,

Wow, I never knew you had to deal with such hostilities. Don't people realise that you are providing these distro's and support in your own time? I'm using Nutyx with Enlightenment and it rocks! Don't let the haters get you down and keep up the great work!

I am not a hater . I tell what i have discovered .
General / Re: Lxqt is broken
« Last post by devlin7 on Sat Sep 23 05:38:00 2023 »
Hi Thierry,

Wow, I never knew you had to deal with such hostilities. Don't people realise that you are providing these distro's and support in your own time? I'm using Nutyx with Enlightenment and it rocks! Don't let the haters get you down and keep up the great work!
General / Re: Lxqt is broken
« Last post by Thierry on Thu Sep 21 09:33:52 2023 »
Welcome to the NuTyX forums.

Thank You for your feedback. We will try to fix the concerned ISO.

General / Lxqt is broken
« Last post by pupuklok on Tue Sep 19 17:26:30 2023 »
I installed lxqt desktop but it does not launch . In the terminal it says that libprocps is not found , but the file is on my system . Lxqt seems to be broken . Also with the cinnamon desktop i cannot launch the system settings because gsound is not found . After i installed gsound it works . Not user friendly . Why there are broken packages ? Lxqt iso and cinnamon iso they are broken and with the case of lxqt it can not fix by the user . I cannot say about the rest of the iso files if they are broken or not but nutyx is not my distro . test the iso files for a correct working desktop . That is my opinion as a newbie. I stick with ubuntu
Installation / luks+ext4 encrypted installation
« Last post by kaippullavvs on Wed Sep 13 14:52:26 2023 »
Read Manual installation and

Used NuTyX_x86_64-23.08.0-OPENBOX.iso

KERNEL=kernel install-nutyx
from chroot under live env, cards install lxdm openbox openbox-jp-theme

Manually installed onto an ext4 partition in virtualbox with BIOS -> Able to boot into the installed OS. Works.

Did the following in virtual box in BIOS mode
created a luks partition with type luks1;
Created a keyfile.bin and added to luks with luksAddKey under /root/.crypto/keyfile.bin

mounted target partition (luks opened) onto /mnt/hd;installed nutyx;
chroot;installed cryptsetup grub;
created grub.cfg;mkinitramfs <kernel version>;
Edited grub.cfg added initrd line

As expected grub.cfg is having cryptomount line;
During booting of OS, grub is asking for passphrase; After supplying passphrase, grub menu;booting proceeds and gets into emergency shell.

Observed the following in the initramfs emergency shell.
keyfile.bin is avl in the appropriate directory.
dm-mod dm-crypt etc modules are avl under /lib/modules/<kernel version>/kernel/drivers/md/ folder

The error message shown in the screen before the emergency shell prompt:
dm-crypt: Unknown symbol key_type_encrypted (err -2)
dm-crypt: Unknown symbol key_type_trusted (err -2)
device-mapper: table: 254:0 crypt: unknown target type
device-mapper: ioctl: error adding target to table
device-mapper: reload ioctl on CROOT (254:0 ) failed. invalid argument

I observed that dm-crypt is not listed under lsmod. dm-mod is added.
So I executed
modproble dm-crypt
It emits the following error:
modprobe: can't load module dm-crypt: Unknown symbol in module or unknown parameter

Has anyone successfully installed onto an encrypted partition.
Have I missed any steps.
Any thoughts?
Installation / Nutyx on Mac hardware
« Last post by HammerheartBloodeagle on Wed Sep 13 05:19:56 2023 »
Hello everyone

First off, fantastic distro. It's super speedy, cards is a great package manager also.

So right to the crux of my problem -- as per the title I am using Nutyx on Mac hardware, more specifically a MacBook Pro A1278, from 2012.
The Apple EFI usually plays well with Linux, with some exceptions Nutyx unfortunately being one of them.
The install itself goes well, with the exception of the bootloader, but I can boot in the installed system post-install.
I tried the option in Advanced to configure the bootloader but this fails and drops me in a shell.
So no big deal, I'll reinstall, boot in the system and fix it myself.
Just to be sure, I mount /dev/sda1 to /boot, then install GRUB via cards.
Due to this quirky EFI, I used grub-install --target=x86_64-efi --efi-directory=/boot --removable to install GRUB, and then grub-mkconfig -o /boot/grub/grub.cfg.
Both steps complete without errors but GRUB does not find any Linux image.
On reboot I am greeted by the file folder with a question mark on it, aka No OS found.
The Nutyx documentation says to install efibootmgr. It works, but returns "EFI variables are not supported on this system".
After some research, I found that maybe the module is simply not loaded, and that doing modprobe efivarfs could fix it.
So then I turned to rEFInd, and has the same EFI variables not supported issue.
I spent the evening tinkering with it, to no avail and I am a bit at a loss.
Any other Mac users amongst us? Or am I the lone nutcase? 🤣
I just love this old Mac.
Beginners / Re: Software request
« Last post by devlin7 on Tue Aug 15 21:57:54 2023 »
For the record I did try to build my own soundconverter package from based on the documentation. The download worked but it had a hissy fit regarding my NZ locale and refused to go any further. I read a whole heap of forum posts regarding the error and ended up using flatpak :-( . I looked at Musicbrainz and just decided that was going to be too hard for me.
Beginners / Software request
« Last post by devlin7 on Tue Aug 15 04:05:47 2023 »
I see the cards system has the MusicBrainz library but I don't see the front end Picard anywhere. I also noted that there isnt a single sound converter such as soundconverter or ciano. Is this something we need to compile ourselves? I obviously can pull via Flatpak but I would rather not.

Just curious to know what others do.
Beginners / Re: Nutyx Enlightenment
« Last post by devlin7 on Tue Aug 15 04:02:39 2023 »
Installing pipewire seem to resolve whatever Bluez was missing to connect audio via Bluetooth.
Beginners / Nutyx Enlightenment
« Last post by devlin7 on Thu Aug 10 21:21:03 2023 »

I have been trying to get Bluetooth to connect to an audio device without luck. Connects and disconnects. Bluetooth works for non audio devices without issue. Had a similar issue with Void linux and it was related to Pulse Audio, more specifically permissions. By adding my user to Pulse group in /etc/group it resolved the issue. Problem is, with Nutyx, Pulse audio is installed but I don't see it in /etc/group. Suggestions?
Pages: 1 [2] 3 4 ... 10