Recent Posts

Pages: 1 ... 7 8 [9] 10
81
Tips and Tricks / Creating a new package: gforth
« Last post by bci_ on Tue May 05 13:47:08 2020 »
I'm working on installing a custom package, gforth https://www.gnu.org/software/gforth/

I'm using this package file:

Code: [Select]
name=gforth
version=0.7.3
release=1
source=(https://ftp.gnu.org/gnu/${name}/${name}-${version}.tar.gz)

build() {
cd ${name}-${version}
./configure
make
make DESTDIR=$PKG install
}
I've made the directory /usr/ports/perso/gforth, and invoke

Code: [Select]
sudo pkgmk -d
Everything works smooth, but at one point I get
Code: [Select]
make[3]: Leaving directory '/usr/ports/perso/gforth/work/src/gforth-0.7.3'
make[2]: Leaving directory '/usr/ports/perso/gforth/work/src/gforth-0.7.3'
make[1]: Leaving directory '/usr/ports/perso/gforth/work/src/gforth-0.7.3'
=======> ERROR: Building '/usr/ports/perso/gforth/gforth1588685885x86_64.cards.tar.xz' failed.

To check my work, I went ahead and installed the application  normally (not as a package). The installation went through smoothly (so I know it's not a problem with the application itself), and then, for kicks, I went ahead and attempted to complete the package installation - and it worked! I was then able to add the package and have it on my system. However, to make sure my package formula was correct, I uninstalled the package, and got rid of the conventional installation. That is, no more 'gforth' files on my system, except the Pkgfile in gforth's ports folder.

I reattempt the install, and I get this error. When I had succeeded in installing the package, I did, in fact, get that tar.xz file, and was able to use it to fully install the package.
82
General / Re: NuTyX JWM ISO - Internet refuses to work
« Last post by Thierry on Sun May 03 05:52:58 2020 »
Thank you for your feedback.
Enjoy NuTyX
83
General / Re: NuTyX JWM ISO - Internet refuses to work
« Last post by bci_ on Sat May 02 18:10:03 2020 »
Hi Thierry,

Your fix worked!  And I love the fact that Bluetooth works in NuTyX :)

So far, so good. Let's see how this goes.
84
General / Re: NuTyX JWM ISO - Internet refuses to work
« Last post by Thierry on Sat May 02 15:19:38 2020 »
Hi bci_

Sorry for this inconvenience. You just need to delete one file and reboot:

Code: [Select]
sudo rm /etc/NetworkManager/conf.d/no-dns-update.conf
Then you reboot.

I did fix this issue 4 days ago

Good luck
85
General / NuTyX JWM ISO - Internet refuses to work
« Last post by bci_ on Sat May 02 15:03:45 2020 »
I just installed Miyo's JWM ISO on a dedicated partition on my laptop. I normally use wireless from my laptop.  When I configure Wifi from the lower right-hand
Wifi icon, everything seems to work: I enter my SSID, my password, and Conky says I have uptime.  But, when I try to ping a domain name, say

Code: [Select]
ping -c 3 gnu.org
I get nothing, and eventually reports something like  "unknown host".  I also try to sync in the flcards app, and it reports "!! download failed !!".

I've even tried using a wired connection, and, to my amazement, the exact same thing happened.

This is quite odd, as this is the first time I'm experiencing this with a Linux distro. If there's any configuration file you need to see, let me know - the system looks like it uses NetworkManager, and I'm somewhat unfamiliar with that app.
86
Obsolet / NuTyX 2020328 JWM and Openbox Miyo Linux Available
« Last post by Thierry on Tue Mar 31 08:23:28 2020 »
I'm glad and proud to annonce the release of the new NuTyX Miyo Linux ISO.

https://www.youtube.com/watch?v=6NZujthy3Gg

You can find the ISOs on the download page or on sourceforge website directly.
87
Obsolet / Re: Update of Miyo NuTyX 11.3 need manual intervention
« Last post by oyim on Fri Mar 20 07:02:35 2020 »
I just saw this. Thank you Thierry. I didn't know it would have to be removed. I know when I upgraded my NuTyX installation (the one that I build the .isos on), I had to make a new panel again.  ;D
88
Obsolet / Re: Music
« Last post by oyim on Fri Mar 20 07:00:04 2020 »
Could be a nice music theme for your next video
Yes, I really like his style too. I would love to use his music, but I don't know if it's copyrighted.  :-[
89
ISOs, initrd, initramfs / Re: Question on install
« Last post by Thierry on Sun Mar 15 09:28:02 2020 »
Shutdown on KDE is a bit boggy, some times it works some times not
90
ISOs, initrd, initramfs / Re: Question on install
« Last post by msb on Sat Mar 14 23:03:51 2020 »
I even attached an external usb mouse but that did not work. If i install will i face the same issue, is there a workaround?
1. open a terminal if you can
2. as explain in http://nutyx.org/en/finish-up#21
Code: [Select]
sudo cards install xorg-xf86-input-synaptics
About your boot problem, I'm sorry I cannot really help you as they are so many differnet cases.

Thanks. I could get the mouse working using synaptics package. I was able to detect nutyx by applying grub on the other distro. I installed kde and removed mate DE that i originally installed. So when i shutdown my system it just shows a cursor on empty screen. I need to press power button to shut down the system. Is there any package/library that i am missing or removed while uninstalling mate?
Pages: 1 ... 7 8 [9] 10