Author Topic: Change language in Mate?  (Read 1156 times)

boss1966

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Change language in Mate?
« on: Tue Oct 03 10:06:15 2017 »
can i change the language in Mate?
« Last Edit: Tue Oct 03 11:45:53 2017 by tnut »

Thierry

  • Administrator
  • Sr. Member
  • *****
  • Posts: 408
  • Karma: +6/-0
  • Gender: Male
    • NuTyX distribution
Re: Change language in Mate?
« Reply #1 on: Tue Oct 03 11:45:43 2017 »
What's shows following command ?
Code: [Select]
cards config|grep Locale

boss1966

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Change language in Mate?
« Reply #2 on: Tue Oct 03 15:11:36 2017 »
Locale   : de

Thierry

  • Administrator
  • Sr. Member
  • *****
  • Posts: 408
  • Karma: +6/-0
  • Gender: Male
    • NuTyX distribution
Re: Change language in Mate?
« Reply #3 on: Tue Oct 03 16:03:32 2017 »
And nothing is in german?

Can you check if all the german mate packages are installed:
Code: [Select]
cards list|cut -d " " -f2|grep de$|more
« Last Edit: Tue Oct 03 19:34:38 2017 by tnut »

boss1966

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Change language in Mate?
« Reply #4 on: Tue Oct 03 20:15:47 2017 »
on console everything is in german. In Mate everything is in english.

boss1966

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Change language in Mate?
« Reply #5 on: Tue Oct 03 20:48:57 2017 »
the german packages seemed to be installed. I installed gnome and in the gnome-settings i change the language to german. But even then everythings still in english :(

So (because the system is really fast) I installed plasma. Changing the Language-Settings to german gives me a german plasma-desktop :). The applications are still in english ... :-[
« Last Edit: Tue Oct 03 21:09:52 2017 by boss1966 »

Thierry

  • Administrator
  • Sr. Member
  • *****
  • Posts: 408
  • Karma: +6/-0
  • Gender: Male
    • NuTyX distribution
Re: Change language in Mate?
« Reply #6 on: Wed Oct 04 06:56:55 2017 »
You could check if the /etc/profile.d/i18n.sh file is correct. Should contains something like:
Code: [Select]
export LANG=de_DE.utf-8
For your locale packages list for mate:
Code: [Select]
cards list|cut -d " " -f2|grep de$|grep mate
And last one what version did you test ?

9.1 or 9.0.95

boss1966

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Change language in Mate?
« Reply #7 on: Wed Oct 04 15:18:57 2017 »
/etc/profile.d/i18n.sh contains export LANG=de_DE.utf-8
cards list|cut -d " " -f2|grep de$|grep mate shows a lot of mate-stuff with the .de ending
uname -a says Linux version 4.9.23-NuTyX-lts
i downloaded the NuTyX_i686-9.1.iso and made a stick with rufus (dd)
« Last Edit: Wed Oct 04 15:57:14 2017 by boss1966 »

Thierry

  • Administrator
  • Sr. Member
  • *****
  • Posts: 408
  • Karma: +6/-0
  • Gender: Male
    • NuTyX distribution
Re: Change language in Mate?
« Reply #8 on: Wed Oct 04 18:34:17 2017 »
How do you login into mate ?
slim, xorg-xdm or lxdm

boss1966

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Change language in Mate?
« Reply #9 on: Wed Oct 04 19:55:25 2017 »
with slim. I first use lxdm,but got problems to log in...

Thierry

  • Administrator
  • Sr. Member
  • *****
  • Posts: 408
  • Karma: +6/-0
  • Gender: Male
    • NuTyX distribution
Re: Change language in Mate?
« Reply #10 on: Wed Oct 04 20:28:44 2017 »
I guess that's the reason... Try to put back lxdm (you will need to delete slim), reboot and choose MATE as interface

boss1966

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Change language in Mate?
« Reply #11 on: Thu Oct 05 09:26:09 2017 »
c'est correct mon seigneur :) Merci beaucoup ...
« Last Edit: Thu Oct 05 19:07:15 2017 by tnut »

Thierry

  • Administrator
  • Sr. Member
  • *****
  • Posts: 408
  • Karma: +6/-0
  • Gender: Male
    • NuTyX distribution
Re: Change language in Mate?
« Reply #12 on: Thu Oct 05 13:21:30 2017 »
Glad that you manage, Great
« Last Edit: Thu Oct 05 19:07:07 2017 by tnut »