Author Topic: Base repo only?  (Read 453 times)

jb74

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Base repo only?
« on: Sun Feb 11 21:05:12 2018 »
Hello, new NuTyX user here...

I installed NuTyX via the install-nutyx script. The system installed properly but it looks like I only got access to the base collection / repository. For instance, here's what I get when trying to install openbox:
Code: [Select]
$ get openbox
cards 2.4.0 install: The package openbox does not exist

The /etc/cards.conf files is as follows:
Code: [Select]
$ cat /etc/cards.conf
dir /var/lib/pkg/depot/base
base /var/lib/pkg/deport/base
locale en

Is there a way to add other collections / repositories?

Thierry

  • Administrator
  • Sr. Member
  • *****
  • Posts: 383
  • Karma: +4/-0
  • Gender: Male
    • NuTyX distribution
Re: Base repo only?
« Reply #1 on: Mon Feb 12 11:18:27 2018 »
Hello, new NuTyX user here...
Welcome to NuTyX

I installed NuTyX via the install-nutyx script. The system installed properly
Well done

but it looks like I only got access to the base collection / repository.
I guess you did follow this tuto which explain how to get an basic NuTyX running.

Is there a way to add other collections / repositories?
Actually, you simply have to add all the collections you want to take in consideration. Most probably you would like all the 17 collections so your  /etc/cards.conf files is as follows: should look like this:
Code: [Select]
dir /var/lib/pkg/depot/kde5-extra|http://downloads.nutyx.org
dir /var/lib/pkg/depot/kde5|http://downloads.nutyx.org

dir /var/lib/pkg/depot/lxqt-extra|http://downloads.nutyx.org
dir /var/lib/pkg/depot/lxqt|http://downloads.nutyx.org

dir /var/lib/pkg/depot/gnome-extra|http://downloads.nutyx.org
dir /var/lib/pkg/depot/gnome|http://downloads.nutyx.org

dir /var/lib/pkg/depot/mate-extra|http://downloads.nutyx.org
dir /var/lib/pkg/depot/mate|http://downloads.nutyx.org


dir /var/lib/pkg/depot/lxde-extra|http://downloads.nutyx.org
dir /var/lib/pkg/depot/lxde|http://downloads.nutyx.org

dir /var/lib/pkg/depot/xfce4-extra|http://downloads.nutyx.org
dir /var/lib/pkg/depot/xfce4|http://downloads.nutyx.org

dir /var/lib/pkg/depot/gui-extra|http://downloads.nutyx.org
dir /var/lib/pkg/depot/cli-extra|http://downloads.nutyx.org

dir /var/lib/pkg/depot/gui|http://downloads.nutyx.org
dir /var/lib/pkg/depot/cli|http://downloads.nutyx.org

dir /var/lib/pkg/depot/base|http://downloads.nutyx.org

base /var/lib/pkg/deport/base
locale en

And if you want to take profit of the updates available on the current branch, you add:

Code: [Select]
version currentto your /etc/cards.conf file

Good luck

Thierry

jb74

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Base repo only?
« Reply #2 on: Mon Feb 12 14:34:32 2018 »
Thank you! Up and running now  :)
« Last Edit: Mon Feb 12 18:12:01 2018 by tnut »

Thierry

  • Administrator
  • Sr. Member
  • *****
  • Posts: 383
  • Karma: +4/-0
  • Gender: Male
    • NuTyX distribution
Re: Base repo only?
« Reply #3 on: Mon Feb 12 18:12:27 2018 »
Thank you for update