Author Topic: Need Wifi and/or dependency of AppImages  (Read 316 times)

surimelow

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Need Wifi and/or dependency of AppImages
« on: Thu Jan 05 13:24:36 2023 »
Hello. Interesting distro and I would like to salute the developers for creating choices for desktop environment! I'm sure it's a lot of hard work. I wish I could donate but the corporation usually in charge of that dislikes me.

I have installed Nutyx with XFCE. Usually I like to include Wine while testing Linux distros, and it's also involved in my music production. Because it's not available, I resolved using a few music-creation applications enrolled in AppImages. The problem is that I need "libfuse2" or something like that to be able to run AppImages.

I cannot get this library because I cannot have Wifi on this distro. I tried four times to enter the modem password, and each time it falls over. I have logged out, restarted and rebooted, and after log-in and return to desktop, the dialog box remains asking me for the modem password without any further effect.

I have tried to "borrow" online access from Manjaro MATE by doing a "chroot" into my Nutyx install but "cards" program keeps throwing an error saying it cannot resolve to host and doesn't download anything. It seems to be able to display which packages are available for download.

This was from Manjaro MATE:

Code: [Select]
[xx@hp2000pc ~]$ inxi -MNC
Machine:
  Type: Laptop System: Hewlett-Packard product: HP 2000 Notebook PC
    v: 088B110000305910000620100 serial: <superuser required>
  Mobo: Hewlett-Packard model: 1854 v: 64.22 serial: <superuser required>
    UEFI: Insyde v: F.22 date: 10/25/2012
CPU:
  Info: dual core model: Intel Pentium B980 bits: 64 type: MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 1515 min/max: 800/2400 cores: 1: 1926 2: 1104
Network:
  Device-1: Ralink RT5390R 802.11bgn PCIe Wireless Network Adapter
    driver: rt2800pci
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169

If there is more information you require, just please ask for it.

All I want is to have the dependency needed to run AppImages. Either that, or I would have to have Wifi Internet from this installation. In the past I would have given up on this distro easily but I don't want to now.

P.S. I'm sorry if this is in the wrong sub-forum.

Thierry

  • Administrator
  • Hero Member
  • *****
  • Posts: 674
  • Karma: +12/-0
  • Gender: Male
    • NuTyX distribution
Re: Need Wifi and/or dependency of AppImages
« Reply #1 on: Thu Jan 05 13:58:35 2023 »
Hello surimelow

Welcome to the NuTyX forums.

Quote
The problem is that I need "libfuse2"

Under NuTyX is call fuse2:

Code: [Select]
cards search fuse
...
(cli) fuse2 2.9.9 Library that ....
...

cards install fuse2

When you need to chroot into NuTyX, you need to copy your /etc/resolv.conf to the NuTyX/etc/resolv.conf

Good luck

Thierry

surimelow

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Need Wifi and/or dependency of AppImages
« Reply #2 on: Tue Jan 17 00:38:36 2023 »
Hello and thank you for your time.

I've decided to try again and install with a different desktop environment, with KDE. I am writing from the new installation.  :D

Wifi works but the obligated KWallet is very annoying. The system settings doesn't seem to have a way to disable it. I might have to type in my modem password everytime I start this system. It's better than nothing. "cards" works. I have updated the system to kernel v6.0.19 and other things. Installed the library needed to play AppImages.

I knew there was a way to get Wifi going on XFCE but I'm not even Linux intermediate.

Cheers for having a simple straightforward distro installation routine. Although it might help if UUID's were recognized because "/dev/sda2" and such could be unreliable. Cool "neofetch" symbol! Although on my screen it displays in blue, I noticed the Nutyx logo is red with black shield. First found out about the distro on Distrowatch.

Again, thank you for your prompt response and your time in answering me.